Want to contribute? Fork me on Codeberg.org!
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

25 lines
634 B

{
description = "Elnu's NixOS configuration";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
nixvim.url = "github:nix-community/nixvim";
apis.url = "git+https://git.elnu.com/jichan.org/apis.git";
home-manager = {
url = github:nix-community/home-manager;
inputs.nixpkgs.follows = "nixpkgs";
};
};
outputs = inputs@{ self, nixpkgs, home-manager, ... }:
let
user = "elnu";
configDir = "nix-config";
in {
nixosConfigurations = import ./hosts {
inherit (nixpkgs) lib;
inherit inputs nixpkgs home-manager user configDir;
};
};
}